Installation

conda downloads platforms condaversion latest

On all platforms, we recommend to install pyGIMLi via the conda package manager contained in the Anaconda distribution. For details on how to install Anaconda, we refer to: https://docs.anaconda.com/anaconda/install/

A step-by-step guide for Windows users can be found here.

To avoid conflicts with other packages, we recommend to install pygimli in a separate environment. Here we call this environment pg, but you can give it any name. Note that this environment has to be created only once.

Open a terminal (Linux & Mac) or the Anaconda Prompt (Windows) and type:

conda create -n pg -c gimli -c conda-forge pygimli=1.1.0

If you are using Windows or Mac, a new environment named “pg” should be visible in the Anaconda Navigator. If you want to use pygimli from the command line, you have to activate the environment. You can put this line in your ~/.bashrc file so that it is activated automatically if you open a terminal.

conda activate pg

After that you can use pygimli with your text editor of choice and a terminal.

Usage with Spyder or JupyterLab

Depending on your preferences, you can also install third-party software such as the MATLAB-like integrated development environment (https://www.spyder-ide.org):

conda install -c conda-forge spyder

Or alternatively, the web-based IDE JupyterLab (https://jupyterlab.readthedocs.io):

conda install -c conda-forge jupyterlab

Testing

To test if everything works correctly you can do the following:

python -c "import pygimli; pygimli.test(show=False, onlydoctests=True)"

Staying up-to-date

Update your pygimli installation from time to time, if want to have the newest functionality:

conda update -c gimli -c conda-forge pygimli

The only drawback of using conda is that you are bound to the rhythm in which we update the binary packages. Conda also can be seen as a sandbox inside your system and it might be difficult to combine system Python packages and conda pyGIMLi. If you like to keep your pyGIMLi version more recent (including all possible drawbacks of versions that are actively developed) you should compile pyGIMLi using your systems toolchain.

If you want to compile pyGIMLi from source, check out Building from source.